Dedibox et ipv6 : petite aide

14

Vous êtes nombreux depuis la sortie des télésites sur Freebox à essayer de créer votre télésite à partir d'une Dedibox.

Or comme vous le savez, la machine doit être configurée en ipv6 pour fonctionner correctement.

Or un bug dans le kernel linux empêche certaines Dedibox de se voir attribuer le ip v6 automatiquement, comme cela devrait se faire. Si vous êtes concerné par ce bug, voici comment résoudre le problème… 

Sur votre Dedibox, si lorsque vous faites un ifconfig, vous obtenez comme seule ip6 sur votre interface eth0 une ip qui commence par « fe80 : », c'est que vous êtes concerné par le bug.

Pour le résoudre, installez « tcpdump » si vous ne l'avez pas.

Puis, tapez en root :

# tcpdump -i eth0 ip6 -vvv

Attendez quelques secondes, faites ctrl + c afin d'interrompre la commande.

Un ifconfig devrait maintenant afficher votre ipv6 publique en plus de l'ip link vue ci-dessus. Elle commence par 2a01 :

adr inet6 : 2a01 :……

Afin de conserver cette ip, éditez votre fichier /etc/network/interfaces et mettez la en static.

Le bug devrait être corrigé dans une prochaine version du kernel.

Partager

A propos de l'auteur

14 commentaires

  1. vraiment petite aide ! vraiment petite .... enfin... essayez un minimum d'être français. Je site : Pour le résoudre, installez "tcpdump" si vous ne l'avez pas. Puis, tapez en root : j'en passe....

  2. Le bug est au niveau du VIA en faîte l'ipv6 n'est pas "gardé" Pour la mettre en static si on parle de /etc/network/interfaces alors il y a des chances pour avoir une distrib à base de debian. donc pour tcpdump : apt-get install tcpdump faire un backup du fichier network cp /etc/network/interfaces /etc/network/interfaces_`date +%Y%m%d vi /etc/network/interfaces et ajouter : iface eth0 inet6 static address netmask 64 ... ça devrais rouler

  3. ah je reviens de manger et d'autres se sont penchés sur le problème ! Merci la communauté ;-> C'est vrai uq ec'est plus cool avec une minuscule. Ca "tient" même si on reboot ? Suis pas sur ;->

  4. En fait le bug n'est pas forcement au niveau du kernel mais au niveau de VIA ! Des bugs sous linux il y en a toutes les semaines (comme windows) sauf que c'est corrigé dans la journée ;->

  5. Réagir sur le forum